Personal tools
Namespaces
Variants
Actions
Navigation
Projects
Toolbox

How to cut a part of a file for testing

From AC3Filter
Jump to: navigation, search

Remote debugging is very hard task. To track the problem a part of a file with problem is often needed. This guide tells how to cut such part.

[edit] Required programs

In this guide we will use following programs:

[edit] How to cut AVI files.

Run VirtualDub and open your file. With help of the ruler at the bottom locate where the problem occurs and set the position several seconds before the glitch. For example, if glitch occurs at 19min 3sec set it to about 18min 58sec:

How to cut a part of a file for testing-VirtualDub.png

Mark this position as selection start (Edit->Set selection start). How move the position to several seconds after the glitch (19min 10sec in our example) and mark it as selection end (Edit->Set selection end. Well, now we have marked what we need.

Set audio and video output to 'Direct stream copy' (Video->Direct stream copy and Audio->Direct stream copy). This will force VirtualDub not to make any changes on data.

That's all. Now we need just to write output file. If only audio is needed for testing, select File->Save WAV. If both audio and video are required, select File->Save as AVI

Verify the resulting file! Glitch must remain there.

Just Contact author and send the file you made. Do not send the file to the public mailbox! Due to tons of spam attaches are disabled there. Just write a short announce and you'll get an address to send your file to.